加入
发新帖
发表于 2014-1-1 16:34 | 查看: 3011| 回复: 8
用C#写的时候,他总是自动改格式,很讨厌啊,求问如何修改它的规则,以及如何让他不自动。
我还是喜欢什么都手动,方便很多,自动往往不合要求,麻烦得不得了。

比如,打“}”之前是这样的:
2014-01-01_163638.jpg
打了之后就恶心掉了:
2014-01-01_163647.jpg

收藏回复 显示全部楼层 道具 举报

发表于 2014-1-1 18:40
括号里本来就应该缩进吧,不过你这个自动缩进太多了

回复 显示全部楼层 道具 举报

发表于 2014-1-1 20:02
royeegg 发表于 2014-1-1 18:40
括号里本来就应该缩进吧,不过你这个自动缩进太多了

怎么解决呢。。。他这个缩进得。。。

回复 显示全部楼层 道具 举报

发表于 2014-1-1 20:33
你应该用C#标准格式

回复 显示全部楼层 道具 举报

发表于 2014-1-1 20:42
orange030 发表于 2014-1-1 20:33
你应该用C#标准格式

怎么用呢?怎么才能用呢?
他自动的,我都不知道怎么办。

回复 显示全部楼层 道具 举报

发表于 2014-1-1 21:09
Monodevelop上方菜单:Project / Solution Options
在弹出面板里,找到Source Code - Code Formating - Text file
在右侧设置选项里面把Whitespace - Indent width从默认的8改成4即可。
whitespace.png

C#真心好,Monodevelop的自动格式化功能对于代码洁癖的人真心好,谁用谁知道。

回复 显示全部楼层 道具 举报

发表于 2014-1-1 21:16
lancelot_gao 发表于 2014-1-1 21:09
Monodevelop上方菜单:Project / Solution Options
在弹出面板里,找到Source Code - Code Formating - T ...

果然解决啦!!!太感谢啦!!!
个人还是感觉C#有些地方不方便啊。。。
比如js可以"transform.position.x = 1;"而C#...

回复 显示全部楼层 道具 举报

发表于 2014-1-1 21:21
彭必涛 发表于 2014-1-1 21:16
果然解决啦!!!太感谢啦!!!
个人还是感觉C#有些地方不方便啊。。。
比如js可以"transform.positio ...

对,C#语法严格,需要适应一下。

回复 显示全部楼层 道具 举报

发表于 2014-1-1 21:22
lancelot_gao 发表于 2014-1-1 21:21
对,C#语法严格,需要适应一下。

明明是麻烦。。。还自称严格。。。

回复 显示全部楼层 道具 举报

您需要登录后才可以回帖 登录 | 加入

搜索

繁體   

返回顶部